Główny Pc I Mac Czy w wiadomościach e-mail jest rozróżniana wielkość liter?

Czy w wiadomościach e-mail jest rozróżniana wielkość liter?



Istnieje wiele nieporozumień dotyczących tego, czy w adresach e-mail jest rozróżniana wielkość liter, czy nie. Niektórzy twierdzą, że są, podczas gdy inni twierdzą, że nie. Więc kto ma rację? W tym artykule przyjrzymy się, czy w adresach e-mail rozróżniana jest wielkość liter, czy nie.

Czy w wiadomościach e-mail jest rozróżniana wielkość liter?

Co tworzy adres e-mail?

Adres e-mail składa się z trzech części – części lokalnej (znanej również jako nazwa użytkownika), znaku @ i części domeny. Każda część ma swoją własną rolę i podlega własnemu zestawowi reguł. Oto krótki przegląd.

Zgodnie ze standardem lokalna część adresu e-mail może mieć długość do 64 znaków i może składać się z ograniczonego zestawu znaków. Należą do nich wielkie i małe litery alfabetu łacińskiego, cyfry od 0 do 9, kropka i znaki specjalne. Znaki specjalne to ` [chronione przez pocztę e-mail] #$%^&*()_-+=[]{}~. Jest on połączony z częścią domeny znakiem @.

Część domeny może mieć do 255 znaków. Może zawierać litery alfabetu łacińskiego (zarówno małe, jak i duże), cyfry od 0 do 9 oraz myślnik. Łącznik nie może rozpoczynać ani kończyć części domeny.

Można również używać symboli międzynarodowych, ale o tym później.

Czy wielkość liter jest wrażliwa?

Prawidłowa odpowiedź na to pytanie brzmi zarówno tak, jak i nie. Według RFC 5321 , lokalna część adresu e-mail uwzględnia wielkość liter. Oznacza to, że teoretycznie [email protected] to nie to samo, co [email protected] Jednak dostawcy poczty e-mail mogą traktować lokalne części jako wrażliwe i niewrażliwe na wielkość liter.

Na przykład [email protected] , [email protected] i [email protected] są teoretycznie różnymi adresami e-mail. Łatwo zauważyć, w jaki sposób może to spowodować problemy i zmniejszyć komfort użytkownika, jeśli serwer poczty zdecyduje się traktować lokalne części jako wrażliwe na wielkość liter. Dlatego wielu dostawców traktuje lokalną część adresu e-mail jako niewrażliwą na wielkość liter.

jak usunąć wszystkie kontakty na iPhonie

Jeśli chodzi o część domenową, RFC 1035 stanowi, że zawsze nie jest rozróżniana wielkość liter. Oznacza to, że możesz pisać małymi literami, dużymi literami lub dowolną kombinacją tych dwóch, a Twój e-mail trafi pod ten sam adres. W praktyce [email protected] , [email protected] i [email protected] to ten sam adres e-mail.

W praktyce

Chociaż w adresach e-mail jest tylko częściowo rozróżniana wielkość liter, ogólnie można uważać, że wielkość liter nie ma znaczenia. Wszyscy główni dostawcy, tacy jak Gmail, Yahoo Mail, Hotmail i inni, traktują lokalne części adresów e-mail jako niewrażliwe na wielkość liter. Biorąc to pod uwagę, powinieneś sprawdzić zasady dostawcy poczty e-mail, z którym chcesz utworzyć wiadomość e-mail.

Nawiązując do poprzedniego punktu, wyżej wspomniany RFC 5321 zaleca, aby nowe adresy e-mail były tworzone wyłącznie małymi literami, aby uniknąć potencjalnych pomyłek i problemów z dostarczaniem.

Z drugiej strony, jeśli twój przyjaciel lub kolega ma adres e-mail z kombinacją wielkich i małych liter, zaleca się napisanie go tak, jak podczas wysyłania mu wiadomości e-mail. Niezastosowanie się do tego może spowodować, że e-mail nie zostanie dostarczony. Nie jest to jednak problem w przypadku głównych dostawców poczty e-mail, takich jak Gmail, Yahoo Mail, Hotmail i innych.

Ponadto Gmail jest również niewrażliwy na kropki znajdujące się w lokalnej części wiadomości e-mail, jeśli chodzi o identyfikację konta użytkownika. Oznacza to, że jeśli konto [email protected] istnieje, nie będzie można zarejestrować [email protected] lub [email protected]

Umiędzynarodowienie

Pierwotnie adresy e-mail mogły być rejestrowane tylko przy użyciu liter alfabetu łacińskiego, cyfr i ograniczonego zestawu znaków specjalnych ASCII. Jednakże IETF (Internet Engineering Task Force) opracowała następnie zasady i standardy dotyczące włączania znaków międzynarodowych.

RFC6530 był pierwszym, który uwzględnił i uregulował użycie znaków międzynarodowych. RFC6531 rozszerzone na zasady i standardy. Następnie zasady i standardy zostały zaktualizowane poprzez RFC6532 i RFC6533 .

Możesz teraz zarejestrować adres e-mail, używając szerokiej gamy alfabetów, znaków i skryptów. Niektóre z najczęściej używanych to znaki łacińskie ze znakami diakrytycznymi, alfabet grecki, tradycyjne chińskie znaki, znaki japońskie (hiragana, katakana i kanji), cyrylica, kilka pism indyjskich, a także szereg innych.

Włączenie i zgodność z międzynarodowymi adresami e-mail różni się w zależności od dostawcy. Nawet niektórzy z największych dostawców nie są w pełni kompatybilne z adresami międzynarodowymi. Na przykład Google umożliwia wysyłanie wiadomości e-mail na adres międzynarodowy, ale nie pozwala na jego utworzenie. Outlook 2016 ma podobną funkcjonalność.

Wniosek

W przeciwieństwie do części nazwy domeny, lokalna część adresu e-mail uwzględnia wielkość liter. Biorąc to pod uwagę, wielu dostawców poczty e-mail decyduje się ignorować rozróżnianie wielkości liter w części lokalnej ze względów praktycznych i zachęcać ludzi do tworzenia wiadomości e-mail wyłącznie z małymi literami.

Ciekawe Artykuły

Wybór Redakcji

Jak pozbyć się mojej sztucznej inteligencji w Snapchacie
Jak pozbyć się mojej sztucznej inteligencji w Snapchacie
Chociaż technologia ma wiele zalet, prawdopodobnie chcesz, aby Twoi prawdziwi przyjaciele byli na szczycie czatu na Snapchacie. Jednak zamiast tego platforma przypięła tam My AI. Na szczęście istnieją sposoby, aby przywrócić przyjaciół
Archiwa tagu: Windows 10 Lean
Archiwa tagu: Windows 10 Lean
Zmień folder wirtualnych dysków twardych Hyper-V w systemie Windows 10
Zmień folder wirtualnych dysków twardych Hyper-V w systemie Windows 10
Możesz zmienić folder używany do przechowywania dysków wirtualnych dla maszyn wirtualnych Hyper-V w systemie Windows 10. Pliki dysków wirtualnych to największe pliki maszyny wirtualnej.
Jak uzyskać zweryfikowany znacznik wyboru (dawniej koronę) w TikTok
Jak uzyskać zweryfikowany znacznik wyboru (dawniej koronę) w TikTok
Jeśli spędziłeś trochę czasu na TikTok, być może zauważyłeś, że mała ikona korony, która była na profilach niektórych użytkowników, teraz zniknęła. To dlatego, że te korony zostały zastąpione zweryfikowanymi znacznikami, takimi jak
Jak włączyć podświetlenie klawiatury w laptopie HP
Jak włączyć podświetlenie klawiatury w laptopie HP
Podświetlenie klawiatury to świetny sposób na korzystanie z laptopa HP w ciemności, a jego włączenie jest łatwe. Wystarczy przełączyć go za pomocą dedykowanego klawisza podświetlenia. Oto jak to się robi.
Jak otworzyć nowe okno aplikacji komputerowej z ekranu Start
Jak otworzyć nowe okno aplikacji komputerowej z ekranu Start
W systemie Windows 8 za każdym razem, gdy uruchamiasz drugą instancję (nowe okno) już uruchomionej aplikacji komputerowej, na ekranie startowym nie jest uruchamiana nowa instancja tej aplikacji. Po prostu przełącza się do już uruchomionego okna aplikacji komputerowej. Może to być bardzo denerwujące. Aby otworzyć inne okno tego samego programu, musisz
Jak wyciszyć się w Apex Legends
Jak wyciszyć się w Apex Legends
Apex Legends to popularna gra zespołowa dla wielu graczy, w którą możesz grać ze znajomymi lub przypadkowymi osobami. Ponieważ praca zespołowa jest niezwykle ważną częścią tej gry, komunikacja z kolegami z drużyny jest niezbędna.